ЗАКРЫТЬ
Правила форума Гаранты форума
Размещение рекламы AMX-X компилятор

Здравствуйте, гость Вход | Регистрация

^ Место доступно для покупки 3500р/мес ^

Наши новости:

11-апр
02-дек
17-апр
30-дек


История благодарностей участнику gavrilyuc ::: Спасибо сказали: 6
Дата поста: В теме: За сообщение: Спасибо сказали:
13.12.2015, 13:33 воспроизведение анимации
вот обсуждение на похожую тему: https://forums.alliedmods.net/showthread.php?t=189615
AndrewZ
17.4.2015, 19:44 *** [ОБХОД ПРОТЕКТОРОВ] ***
почему бы, просто не выпить пару таблеток поносного и не посидеть в туалете с мыслями что ты делаешь...
Если тебе не нравится что есть люди которые не хотят что бы изменялось.
Сделай меню, Типо, для корректной игры, вы должны согласится на изменение кваров на клиенте... если пользователь сам нажмёт: "Да, Я Согласен."
Тогда можно и всякими примотками это бомбить... Так и тебе Угодно, и Другим нормально. Да и "сирво-пиарщики" не будут визжать...
VkriterT
29.3.2015, 16:34 Player Speed 1000
Здравствуйте, решил создать тему, по причине того что есть люди которые знают как можно "коректно" без изменений клиентских кваров, изменить скорость передвижение игрока.
К примеру на скорость 1000 ...

Вот пример того как я устанавливаю скорость передвижение игрокам:
Код:

// Код Для примера, не нужно придираться к коду.
new g_flMaxSpeed = 1000.0;
if(get_cvar_float("sv_maxspeed") < g_flMaxSpeed) set_cvar_float("sv_maxspeed", g_flMaxSpeed);
RegisterHam(Ham_Item_PreFrame, "player", "player_speed", 1);
/////////////////////////
public player_speed(id) {
set_pev(id, pev_maxspeed, g_flMaxSpeed);
}

Скорость работает только у тех у кого стоит: cl_forwardspeed, cl_sidespeed, cl_backspeed на 1000 и выше...
а у остальных ни-ни...
Собственно и вопрос:
Как реализовать установку скорости свыше чем 400, без изменений клиенских кваров: cl_forwardspeed, cl_sidespeed, cl_backspeed ?
VkriterT
2.2.2015, 13:42 AMXX < 183, MySQL и кириллица
voed,
Стоп. Ты информацию из бд(Имеется введу русские символы) пытаешься вывести в плагине?
у меня была похожая проблема, только с денвером, я в my.ini(или my.cnf) прописал везде чарсет на utf8.
После чего у меня работало(естествено плагин должен быть utf8 Not Bom)


Ещё есть вероятность того что тебе нужно установить самой базе кодировку:
Код
-- вместо <Data Base Name> название полное название бд.
alter database <Data Base Name> CHARACTER SET utf8 COLLATE utf8_unicode_ci;
Safety1st
25.1.2015, 18:55 body, hands
DELETED

этот код "типо" должен изменять руки...
Главное что бы были модельки...

пару баг которые я не смог зализать :D

выстрел:
pre -- меняется на установленые.
после pre меняются на 0.
post -- меняется на установленые.

так же и с перезарядкой...

Возможно я что-то не то набросал в код, поправьте меня.
JIuXeP